Page 1 sur 1

Installation serveur - mise à jour et dépots apt-get

Posté : 26 Oct 2017, 07:24
par erics
Bonjour,
je viens de remettre en place le serveur qui délivre les paquets de mise à jour et les scripts de préconfiguration. Ces deux adresses de serveurs sont ancrées profondément dans les sources d'AbulÉdu et font référence à apt.ryxeo.com et anet.ryxeo.com (et peut-être d'autres que nous allons découvrir au fur et à mesure).

Ces deux adresses (web) sont protégées par un certificat SSL ... certificat qui est arrivé à échéance mi septembre et donc depuis cette date les mises à jours et installations serveurs "coincent".

C'est maintenant de l'histoire ancienne, j'ai fait le nécessaire, déplacé ces deux adresses sur une nouvelle machine sur laquelle j'ai pu mettre en place un certificat ssl gratuit et donc tout devrait être de nouveau opérationnel.

Si vous avez des erreurs de ce type (416 Requested Range Not Satisfiable) lorsque vous lancez un apt-get update:

Code : Tout sélectionner

W: Impossible de récupérer xxxxxxxxxxx 416 Requested Range Not Satisfiable
Vous devrez alors manuellement avec le compte root sur le serveur lancer la commande suivante:

Code : Tout sélectionner

rm /var/lib/apt/lists/partial/*
Cordialement,
Éric

Re: Installation serveur - mise à jour et dépots apt-get

Posté : 30 Jan 2018, 09:11
par CrowQuiGnole
Bonjour,

Je suis nouveau sur le forum Abuledu, j'espère avoir posté ma question au bon endroit. Je suis technicien support dans les écoles, et j'ai besoin d'installer un serveur Abulédu. Lors de l'étape de mise à jour (tout va bien jusque là), il y a beaucoup d'erreur "404 NOT FOUND". Je pense que certains dépôts ont été déplacés. Après l'étape de mise à jour, le serveur redémarre, et boucle sur la mise à jour. Je reviens systématiquement sur la page WebAdmin, à l'étape de mise à jour. Y-a-t-il une correction que je peux apporter, ou faut-il attendre une mise à jour de l'iso?

En vous remerciant par avance ;)

Re: Installation serveur - mise à jour et dépots apt-get

Posté : 31 Jan 2018, 09:19
par CrowQuiGnole
Je me permets de me répondre, peut-être que cela aidera quelqu'un dans le futur :

Voilà une solution trouvée sur le net. Je suis en train de tester, les MAJ ont l'air de bien se faire :

https://doc.ubuntu-fr.org/old-releases

"À l'aide d'un éditeur de texte simple exécuté en mode administrateur , ouvrez le fichier /etc/apt/sources.list ;
Appliquez les changements suivants dans le document :
Remplacez toutes les instances http://xx.archive.ubuntu.com/ubuntu, où xx est un code de pays (fr, ca, ch, be…), par http://old-releases.ubuntu.com/ubuntu ;
Remplacez toutes les instances http://security.ubuntu.com/ubuntu par http://old-releases.ubuntu.com/ubuntu ;
Retirez toutes les lignes faisant référence au dépôt partner ;
Retirez toutes les lignes faisant référence au serveur http://extrasubuntu.com/ubuntu.
Enregistrez vos modifications"

Dés le démarrage du serveur, lorsque "Appuyez sur Alt+F1 pour ... et Alt+F7 pour ..." apparait, et avant l'ouverture de WebAdmin, j'ai lancé un ternimal, je me suis connecté en ROOT et j'ai utilisé NANO, natif sous UBUNTU, pour modifier /etc/apt/sources.list


Cordialement

Re: Installation serveur - mise à jour et dépots apt-get

Posté : 31 Juil 2018, 11:11
par erics
Bonjour,
je constate que j'ai oublié de passer sur le forum depuis trop longtemps :-(

Votre solution ne devrait pas être nécessaire, un script de post installation et lancé avant la 1ere mise à jour "corrige" tout ça ...